How to install Inksmoto into Inkscape

From X-Moto
Revision as of 21:57, 8 September 2013 by XMOTOFREAK (talk | contribs) (Installation on Mac OS X)
Jump to: navigation, search

Using Inksmoto 0.6.0

About

Inksmoto 0.6.0 is an extensions tool for Inkscape that will let you create X-Moto levels. This documentation is for Inksmoto 0.6.0 only. Inksmoto 0.6.0 requires Python, python-tk, and Inkscape.

Required software

Inksmoto 0.6.0 requires:

     *Inkscape 0.46 or 0.47(or any version of Inkscape)
     *Python(any version of Python)
     *python-tk

Installation on Windows

To install for Windows XP, 2000, Vista, 7, and 8, download and execute this file: http://download.tuxfamily.org/xmoto/svg2lvl/0.6.0/Inkscape-0.46.1_inksmoto-0.6.0_win32.exe

Insallation on Linux

Ubuntu and Linux

For Debian/Ubuntu and Linux users, run terminal and type in:

sudo apt-get install inkscape python python-tk libglade2-0

Next, download and unpack Inksmoto 0.6.0: http://download.tuxfamily.org/xmoto/svg2lvl/0.6.0/inksmoto-0.6.0.tar.gz

Next, copy the files from the extracted extensions directory, and paste it in the Inkscape extensions folder.

/usr/share/inkscape/extensions

Launch Inkscape and test the Inksmoto extensions. If you installed it correctly, you should have no problem with Inksmoto.

Installation on Mac OS X

Its pretty simple to install Inksmoto in Mac OS X. You just need 4 things.

Required software

  • Inkscape 0.48
  • Python 2.7
  • PIL 1.1.7a2
  • Inksmoto 0.6.0

Note: Inksmoto 0.6.0 is not compatible with Inkscape 48.1, nor 48.2. 0.47 and 0.48 are both compatible with it.

Downloading and installing dependencies

Download the Inkscape 0.48 from here: http://sourceforge.net/projects/inkscape/files/inkscape/0.48/Inkscape-0.48.0-1-LEOPARD%2B.dmg/download

After its finished, open the .dmg and drag the Inkscape.app into your Applications folder, to install it.

Python 2.7: http://www.python.org/ftp/python/2.7/python-2.7-macosx10.5.dmg

PIL 1.1.7a2: http://effbot.org/media/downloads/PIL-1.1.7a2-py2.5-macosx10.5.mpkg.zip(Even though it says its for Python 2.5, its compatible with Python 2.7).

Install them.

Installing Inksmoto

Download Inksmoto 0.6.0 from here: http://download.tuxfamily.org/xmoto/svg2lvl/0.6.0/inksmoto-0.6.0.tar.gz

Unzip it with the appropriate Mac OS X tool, then drag the contents of the extracted extensions directory, into your Inkscape extensions folder.

Launch Inkscape, to test if everything works fine for you.

Downloading and installing Inkscape

Here is a list of recommended and latest version of Inkscape here. Its a universal binary, so it will both work on PPC and Intel macs.

Inkscape 0.45.1 for OS X Panther: http://sourceforge.net/projects/inkscape/files/inkscape/0.45.1/Inkscape-0.45.1-2-UNIVERSAL.dmg/download

Inkscape 0.46 for OS X Tiger only: http://sourceforge.net/projects/inkscape/files/inkscape/0.46/Inkscape-0.46-3.TIGER.UNIVERSAL.dmg/download

Inkscape 0.48.1(if you are lower than 10.5.8): http://sourceforge.net/projects/inkscape/files/inkscape/0.48.1/Inkscape-0.48.1-1-LEOPARD+.dmg/download

Inkscape 0.48.2(if you on 10.5.8 or higher), 10.6 Snow Leopard, 10.7 Lion, and 10.8 Mountain Lion: http://sourceforge.net/projects/inkscape/files/inkscape/0.48.2/Inkscape-0.48.2-1-SNOWLEOPARD.dmg/download

Here is more Inkscape versions that you can try out with Inksmoto 0.6.0, just make sure get the right version for it: http://sourceforge.net/projects/inkscape/files/inkscape/

To install Inkscape, simply drag the Inkscape.app into your Applications folder.

Downloading and installing Python and PIL

Next, we need to get Python, and PIL.

Python 2.5 for 10.3.9 and later(but its meant for Tiger only): http://pythonmac.org/packages/py25-fat/dmg/python-2.5-macosx.dmg

If your on Mac OS X 10.5 or higher, then download Python 2.7 here: http://www.python.org/ftp/python/2.7/python-2.7-macosx10.5.dmg

PIL 1.1.7a2(Both works for Python 2.5, and 2.7): http://effbot.org/media/downloads/PIL-1.1.7a2-py2.5-macosx10.5.mpkg.zip

Follow the on-screen instructions for installing Python and PIL.

Installing Inksmoto 0.6.0

Next, download Inksmoto 0.6.0 from here: http://download.tuxfamily.org/xmoto/svg2lvl/0.6.0/inksmoto-0.6.0.tar.gz

Extract it with the appropriate Mac OS X Tool, then copy the files from the extracted extensions directory, into the Inkscape extensions folder.

Inkscape.app/Contents/Resources/extensions

Then launch Inkscape, and test to see if Inksmoto 0.6.0 is installed and working properly.

Test the installation to see if its ok

There is a couple of ways to test to see if Inksmoto 0.6.0 is properly installed correctly.

  • 1st way, go to the "Extensions/Effects" menu to see if the is an Xmoto extensions menu.
  • 2nd way, save the .svg as a X-Moto level(.lvl).

If you still have any problems, come by the IRC or the X-Moto chat to see why it failed.

Making levels using Inksmoto 0.6.0

You can find the tutorial for 0.6.0 here: http://wiki.xmoto.tuxfamily.org/index.php?title=Inksmoto-0.6.0

Using Inksmoto 0.7.0

About

Inksmoto 0.7.0 is an extensions tool for Inkscape using to create X-Moto levels. Inksmoto 0.7.0 needs to have any Inkscape version that will work. Inksmoto 0.7.0 will not be using Tcl/Tk, it uses PyGTK for the windows toolkit.

Required software

     *Inkscape(Any version of Inkscape)
     *Python(tested on 2.7)
     *Python-gtk2
     *Python-lxml
     *libglade2-0

Installation of Windows

To install Inksmoto 0.7.0 for Windows XP, 2000, Vista, 7, and 8, download and execute this file: http://download.tuxfamily.org/xmoto/svg2lvl/0.7.0/Inkscape-0.47.1_inksmoto-0.7.0_win32.exe

Installation of Ubuntu/Linux

To install Inksmoto for Ubuntu/Linux, open terminal and type in:

sudo apt-get install inkscape python python-lxml python-gtk2 libglade2-0

Next, download and install Inksmoto 0.7.0 from here: http://download.tuxfamily.org/xmoto/svg2lvl/0.7.0/inksmoto-0.7.0.tar.gz

Extract it, and copy all of the files from the extracted extensions directory, into the Inkscape extensions folder.

/usr/share/inkscape/extensions

Launch Inkscape to test Inksmoto 0.7.0, to make sure it properly installed and working.

Installation on Mac OS X

To install Inksmoto 0.7.0 for Mac OS X, here is a list of dmgs for recommended and latest versions of Inkscape.

For Mac OS X Tiger 10.4: https://dl.dropboxusercontent.com/u/159987131/Inksmoto%20Mac%20OS%20X%20DMGS/Inkscape-0.46-Inksmoto-0.7.0-macosx-UNIVERSAL-TIGER.dmg

For Mac OS X Leopard(If you are lower than 10.5.8): https://dl.dropboxusercontent.com/u/159987131/Inksmoto%20Mac%20OS%20X%20DMGS/Inkscape-0.48.1-Inksmoto-0.7.0-macosx-UNIVERSAL-LEOPARD.dmg

For Mac OS X Leopard(If you on 10.5.8 or higher), 10.6 Snow Leopard, 10.7 Lion, and 10.8 Mountain Lion: https://dl.dropboxusercontent.com/u/159987131/Inksmoto%20Mac%20OS%20X%20DMGS/Inkscape-0.48.2-Inksmoto-0.7.0-macosx-UNIVERSAL-LEOPARD+.dmg

Using Inksmoto 0.7.0 svn for Mac OS X

You can grab the dmgs of Inksmoto 0.7.0 svn version, for testing and reporting bugs.

For Mac OS X Tiger 10.4: https://dl.dropboxusercontent.com/u/159987131/Inksmoto%20Mac%20OS%20X%20DMGS/Inkscape-0.46-Inksmoto-0.7.0-svn-macosx-UNIVERSAL-TIGER.dmg

For Mac OS X Leopard(If you are lower than 10.5.8): https://dl.dropboxusercontent.com/u/159987131/Inksmoto%20Mac%20OS%20X%20DMGS/Inkscape-0.48.1-Inksmoto-0.7.0-svn-macosx-UNIVERSAL-LEOPARD.dmg

For Mac OS X Leopard(If you on 10.5.8 or higher), 10.6 Snow Leopard, 10.7 Lion, and 10.8 Mountain Lion: https://dl.dropboxusercontent.com/u/159987131/Inksmoto%20Mac%20OS%20X%20DMGS/Inkscape-0.48.2-Inksmoto-0.7.0-svn-macosx-UNIVERSAL-LEOPARD+.dmg

Read the README file of how to install it.

There is no maunal way to install Inksmoto 0.7.0. It gets complicated of editing the launcher script, and making a python command. So, just download the premade dmgs above.

Test the installation to see if its ok

There is a couple of ways to test to see if Inksmoto 0.7.0 is properly installed correctly.

  • 1st way, go to the "Extensions/Effects" menu to see if the is an Xmoto extensions menu.
  • 2nd way, save the .svg as a X-Moto level(.lvl).

If you still have any problems, come by the IRC or the X-Moto chat to see why it failed.

Making levels using Inksmoto 0.7.0

You can find the tutorial for 0.7.0 here: http://wiki.xmoto.tuxfamily.org/index.php?title=Inksmoto-0.7.0

Bugs when using Inksmoto 0.6.0, and 0.7.0

Go to this page, if you encounter bugs when using Inksmoto 0.6.0, and 0.7.0, and how to fix them: http://wiki.xmoto.tuxfamily.org/index.php?title=Known_Issues_when_using_Inksmoto

Development version of Inksmoto

Currently, there is no development version of Inksmoto yet. Its not stable and not fully tested, but you can test it here: http://wiki.xmoto.tuxfamily.org/index.php?title=Inkscape-dev