data['title']); if($title_nice != "Main Page") { echo "

"; echo $title_nice; echo "

"; } ?>

Hello... I'd like to build X-Moto on my Mac (10.6.6) and have run into a problem. If I can get the process down, I offer building of future .dmg archives when new releases come out. I am guessing I need to do something about SDL on my system... here's where the build error text starts:

                ~/xmoto-build/build/devel-lite ~/xmoto-build/build
                missing header for unified diff at line 4 of patch
                patching file SDLMain.m
                In file included from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_config.h:34,
                                 from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_stdinc.h:28,
                                 from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_main.h:26,
                                 from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL.h:28,
                                 from SDLMain.m:8:
                /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_config_macosx.h:29:32:In file included from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_config.h:34 ,
                                 from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_stdinc.h:28error: ,
                                 from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_main.h:26AvailabilityMacros.h: No such file or directory,
                                 from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL.h:28
                ,
                                 from SDLMain.m:8:
                /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_config_macosx.h:29:32: error: AvailabilityMacros.h: No such file or directory
                In file included from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_main.h:26,
                                 from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL.h:28,
                from SDLMain.m:8:
                /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_stdinc.h:32:23: error: sys/types.h: No such file or directory
                /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_stdinc.h:35:19: error: In file included from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL_main.h:26stdio.h: No such file or directory,
                                 from /Users/ixohoxi/xmoto-build/sdl/SDL.framework/Headers/SDL.h:28


There's much more I will leave out. If you can throw me some tips I would greatly appreciate it.

Thanks, -Al


This page was last modified on 13 February 2011, at 21:57. This page has been accessed 604 times.

  

Copyright © 2006