Difference between revisions of "Inkscape-0.4.0"

From X-Moto
Jump to: navigation, search
 
Line 1: Line 1:
==TODO==
+
'''Svg made with the 0.2.0 version of svg2lvl are not compatible with this version of svg2lvl.'''
 +
 
 +
=Install=
 +
 
 +
==Windows==
 +
 
 +
To install Inksmoto level editor 0.4.0 on a Windows box, just double-click on the Inkscape-0.45.1_svg2lvl-0.4.0_win32.exe installer.
 +
 
 +
==Linux & Mac OS X==
 +
 
 +
===Required software===
 +
 
 +
* [http://www.inkscape.org/ Inkscape] (>= 0.45)
 +
* [http://www.python.org/ Python] (>= 2.3)
 +
* python-tk
 +
* Svg2lvl converter (0.4.0)
 +
 
 +
To install required software on an Ubuntu box (Festy Fawn):
 +
$ sudo apt-get install inkscape python python-tk python-xml
 +
 
 +
===Installation===
 +
 
 +
$ wget http://download.tuxfamily.org/xmoto/svg2lvl/0.4.0/svg2lvl-0.4.0.tar.gz
 +
$ tar zxvf svg2lvl-0.4.0.tar.gz
 +
$ cd ~/svg2lvl-0.4.0/
 +
$ mkdir -p ~/.inkscape/extensions/
 +
$ cp -f * ~/.inkscape/extensions/
 +
 
 +
=Tutorial=
  
 
Make a tutorial which show 0.4.0 new stuffs
 
Make a tutorial which show 0.4.0 new stuffs

Revision as of 18:56, 19 April 2007

Svg made with the 0.2.0 version of svg2lvl are not compatible with this version of svg2lvl.

Install

Windows

To install Inksmoto level editor 0.4.0 on a Windows box, just double-click on the Inkscape-0.45.1_svg2lvl-0.4.0_win32.exe installer.

Linux & Mac OS X

Required software

  • Inkscape (>= 0.45)
  • Python (>= 2.3)
  • python-tk
  • Svg2lvl converter (0.4.0)

To install required software on an Ubuntu box (Festy Fawn):

$ sudo apt-get install inkscape python python-tk python-xml

Installation

$ wget http://download.tuxfamily.org/xmoto/svg2lvl/0.4.0/svg2lvl-0.4.0.tar.gz
$ tar zxvf svg2lvl-0.4.0.tar.gz
$ cd ~/svg2lvl-0.4.0/
$ mkdir -p ~/.inkscape/extensions/
$ cp -f * ~/.inkscape/extensions/

Tutorial

Make a tutorial which show 0.4.0 new stuffs