data['title']); if($title_nice != "Main Page") { echo "

"; echo $title_nice; echo "

"; } ?>

Contents

Using Inksmoto 0.6.0

About

Inksmoto 0.6.0 is an extensions tool for Inkscape that will let you create X-Moto levels. This documentation is for Inksmoto 0.6.0 only. Inksmoto 0.6.0 requires Python, python-tk, and Inkscape.

Required software

Inksmoto 0.6.0 requires:

     *Inkscape 0.46 or 0.47(or any version of Inkscape)
     *Python 2.5
     *python-tk

Installation on Windows

To install for Windows XP, 2000, Vista, 7, and 8, download and execute this file: http://download.tuxfamily.org/xmoto/svg2lvl/0.6.0/Inkscape-0.46.1_inksmoto-0.6.0_win32.exe

Insallation on Linux

Ubuntu and Linux

For Debian/Ubuntu and Linux users, run terminal and type in:

sudo apt-get install inkscape python python-tk libglade2-0

Next, download and unpack Inksmoto 0.6.0: http://download.tuxfamily.org/xmoto/svg2lvl/0.6.0/inksmoto-0.6.0.tar.gz

Next, copy the files from the extracted extensions directory, and paste it in the Inkscape extensions folder.

/usr/share/inkscape/extensions

Launch Inkscape and test the Inksmoto extensions. If you installed it correctly, you should have no problem with Inksmoto.

Installation on Mac OS X

Its pretty simple to install Inksmoto in Mac OS X. You just need 4 things.

Required software

  • Inkscape 0.48
  • Python 2.5
  • PIL 1.1.7a2
  • Inksmoto 0.6.0

Note: Inksmoto 0.6.0 is not compatible with Inkscape 48.1, nor 48.2. 0.47 and 0.48 are both compatible with it.

Mac OS X versions that work with Inkscape 0.48 is listed here:

  • Mac OS X 10.5 Leopard
  • Mac OS X 10.6 Snow Leopard
  • Mac OS X 10.7 Lion
  • Mac OS X 10.8 Mountain Lion
  • Mac OS X 10.9 Mavericks(Recently, tested by Ade626).
  • Mac OS X 10.10 Yosemite(Recently, tested by me)

Downloading and installing dependencies

Download the Inkscape 0.48 from here: http://sourceforge.net/projects/inkscape/files/inkscape/0.48/Inkscape-0.48.0-1-LEOPARD%2B.dmg/download

After its finished, open the .dmg and drag the Inkscape.app into your Applications folder, to install it.

Python 2.5: http://pythonmac.org/packages/py25-fat/dmg/python-2.5-macosx.dmg

PIL 1.1.7a2: http://effbot.org/media/downloads/PIL-1.1.7a2-py2.5-macosx10.5.mpkg.zip

Install them.

Installing Inksmoto

Download Inksmoto 0.6.0 from here: http://download.tuxfamily.org/xmoto/svg2lvl/0.6.0/inksmoto-0.6.0.tar.gz

Unzip it with the appropriate Mac OS X tool, then drag the contents of the extracted extensions directory, into your Inkscape extensions folder.

Then, launch Inkscape to test if everything is properly installed and works correctly.

Downloading the .dmg to everything

If you don't like installing Inksmoto manually, you can grab the dmg that comes with Inkscape 0.48, Python 2.7, PIL 1.1.7a2, and Inksmoto 0.6.0(Already installed onto Inkscape) here: https://dl.dropboxusercontent.com/u/159987131/Inksmoto%20Mac%20OS%20X%20DMGS/Inkscape-0.48-Inksmoto-0.6.0-macosx-LEOPARD+.dmg

Just make sure you read the README file of how to install Inksmoto. Its Universal, so it will work for PPC and Intel macs.

Test the installation to see if its ok

There is a couple of ways to test to see if Inksmoto 0.6.0 is properly installed correctly.

  • 1st way, go to the "Extensions/Effects" menu to see if the is an Xmoto extensions menu.
  • 2nd way, save the .svg as a X-Moto level(.lvl).

If you still have any problems, come by the IRC or the X-Moto chat to see why it failed.

Making levels using Inksmoto 0.6.0

You can find the tutorial for 0.6.0 here: http://wiki.xmoto.tuxfamily.org/index.php?title=Inksmoto-0.6.0

Using Inksmoto 0.7.0

About

Inksmoto 0.7.0 is an extensions tool for Inkscape using to create X-Moto levels. Inksmoto 0.7.0 needs to have any Inkscape version that will work. Inksmoto 0.7.0 will not be using Tcl/Tk, it uses PyGTK for the windows toolkit.

Required software

     *Inkscape(Any version of Inkscape)(0.91 for Mac only)
     *Python(tested on 2.7)
     *Python-gtk2
     *Python-lxml
     *libglade2-0

Installation of Windows

To install Inksmoto 0.7.0 for Windows XP, 2000, Vista, 7, and 8, download and execute this file: http://download.tuxfamily.org/xmoto/svg2lvl/0.7.0/Inkscape-0.47.1_inksmoto-0.7.0_win32.exe

Installation of Ubuntu/Linux

To install Inksmoto for Ubuntu/Linux, open terminal and type in:

sudo apt-get install inkscape python python-lxml python-gtk2 libglade2-0

Next, download and install Inksmoto 0.7.0 from here: http://download.tuxfamily.org/xmoto/svg2lvl/0.7.0/inksmoto-0.7.0.tar.gz

Extract it, and copy all of the files from the extracted extensions directory, into the Inkscape extensions folder.

/usr/share/inkscape/extensions

Launch Inkscape to test Inksmoto 0.7.0, to make sure it properly installed and working.

Installation on Mac OS X

To download Inksmoto 0.7.0 for Mac, download the dmg here, with the README file: https://www.dropbox.com/s/f47c25gqvmbcjhd/Inkscape-0.91%2864-bit%29-Inksmoto-0.7.0-macosx.dmg?dl=1

Test the installation to see if its ok

There is a couple of ways to test to see if Inksmoto 0.7.0 is properly installed correctly.

  • 1st way, go to the "Extensions/Effects" menu to see if the is an Xmoto extensions menu.
  • 2nd way, save the .svg as a X-Moto level(.lvl).

If you still have any problems, come by the IRC or the X-Moto chat to see why it failed.

Making levels using Inksmoto 0.7.0

You can find the tutorial for 0.7.0 here: http://wiki.xmoto.tuxfamily.org/index.php?title=Inksmoto-0.7.0

Bugs when using Inksmoto 0.6.0, and 0.7.0

Go to this page, if you encounter bugs when using Inksmoto 0.6.0, and 0.7.0, and how to fix them: http://wiki.xmoto.tuxfamily.org/index.php?title=Known_Issues_when_using_Inksmoto

Development version of Inksmoto

Currently, there is no development version of Inksmoto yet. Its not stable and not fully tested, but you can test it here: http://wiki.xmoto.tuxfamily.org/index.php?title=Inkscape-dev


This page was last modified on 11 March 2015, at 17:21. This page has been accessed 14,815 times.

  

Copyright © 2006