Es:Inkscape-0.2.0

From X-Moto
Revision as of 11:24, 26 November 2010 by Wiki.xmoto (talk | contribs) (Reverted edits by Opofefemucu (Talk) to last revision by Trullo)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

English - Català


Documentación para la versión 0.2.0 de svg2lvl


Requisitos Mínimos

Antes que nada

Has de instalar la extensión svg2lvl del Inkscape.

GNU/Linux

Supondremos que has descargado el archivo svg2lvl-*.tar.gz en ~/download/

$ cd ~/download/
$ tar zxvf svg2lvl-*.tar.gz
$ cd svg2lvl-*
$ mkdir -p ~/.inkscape/extensions/
$ cp *.inx *.py ~/.inkscape/extensions/
$ ln -s /usr/share/inkscape/extensions/bezmisc.py ~/.inkscape/extensions/bezmisc.py
$ ln -s /usr/share/inkscape/extensions/inkex.py ~/.inkscape/extensions/inkex.py

Entonces, ya puedes arrancar Inkscape.

Windows

Descomprime el archivo svg2lvl-*.tar.gz que has descargado con tu programa de compresión preferido (unrar, 7-zip, ...). Ves a share/extensions/ dentro del directorio de instalación del Inkscape. Copia dentro de este directorio los archivos .py y .inx del paquete.

Ahora, arranca Inkscape.

Comprueba si la instalación funciona correctamente

  • Comprueba que en el menú 'Effects' hay la entrada 'X-moto'
  • Haz 'Save as...' (Shift-Ctrl-S), y comprueba que puedes seleccionar el formato 'X-Moto Level (*.lvl)'.

Si la instalación no ha sido satisfactoria, por favor ves al IRC para que podamos ayudarte a ver porque ha fallado.

Dibuja un nivel

Abre Inkscape.

Inkscape-empty.png


Ya estas preparado para dibujar un nivel utilizando Inskcape. Mira te los howto's del Inkscape del menú Ayuda.

Inskcape-drawn.png

Pon propiedades a los Objetos

Una vez tengas tu nivel dibujado, has de poner las propiedades de las entidades, bloques y figuras.

Hay dos maneras de hacerlo. Manualmente o utilizando Inkscape effects.

Utilizando los efectos del Inkscape

La manera mas sencilla de cambiar propiedades de objetos.

Selecciona los objetos en los cuales quieres cambiar las propiedades. Ves al menú Effect y elije el submenu X-moto. Y tendras mas submenus para transformar tus objetos en el tipos deseado (Zonas, Bloques, Entidades).

Dependiendo del tipo de objeto, el color cambia. Los colores son muy feos.. pero si tienes alguna idea sobre algún color que pueda quedar mejor, hazlo saber. Agregando una textura de bordillo a un bloque, agrega un horrible color verde en el bordillo del bloque en el Inkscape.

(Información: Solo se actualiza la etiqueta del objeto (Mirate la siguiente sección para mas detalles).)


Por ejemplo, si queremos cambiar el circulo en un bloque dinámico utilizando la textura Texture1 (es un ejemplo, realmente no existe). (Fíjate que puedes seleccionar mea de un objeto a la vez). Primero, seleccionamos la entrada de la derecha del submenu X-moto.

Effect-inkscape.png

Entonces ponemos el nombre de la textura

Effect-param.png

Y aquí esta el resultado. Para ver lo, haz click derecho en un objeto y selecciona object properties.

Effect-result.png

Editalo Manualmente

Otra forma de cambiar las propiedades.

Selecciona un objeto, click derecho y selecciona 'object properties'.

Inskcape-properties.png


Las propiedades se ponen dentro de 'label'. Se separan con un '|'. Si no hay propiedades especificadas, el objeto se coloca como un bloque con la textura por defecto. También puedes rellenar 'id', es útil si escribes un script con código lua para el nivel, porque así tienes los nombres de los bloques, las zonas, etc.. para hacerlos servir en tu script.

Atención :las propiedades son sensibles a las mayúsculas ! Escribe-las exactamente como os mostramos:

Propiedades de Bloques

  • background
  • dynamic
  • usetexture=texture_name
  • edgeTexture=edge_texture_name
  • physics:grip=grip_value

Ejemplos

Un Bloque de fondo (es un bloque en el fondo con el cual el jugador no puede interactuar) utilizando la textura Dark Dirt:

background|usetexture=DarkDirt

Un Bloque dinámico utilizando la textura por defecto:

dynamic

Un Bloque utilizando la textura por defecto:

(no hay nada que poner, dejalo vacío (o deja lo que Inkscape ponga))

Un Bloque utilizando la textura Dark Dirt:

usetexture=DarkDirt

Un Bloque dinámico con hierba utilizando la textura Bricks

usetexture=Bricks|dynamic|edgeTexture=Grass

Un bloque que utiliza la textura Dark Dirt y que cambia la fricción par simular hielo (el valor de grip puede estar entre [1.0 - 50.0], por defecto es 20.0. Si es mas pequeño, el bloque tendrá menos fricción.

usetexture=DarkDirt|physics:grip=1.0

Propiedades de las Entidades

  • typeid=[PlayerStart|EndOfLevel|Strawberry|Wrecker|ParticleSource|Sprite]
  • size=float_number (the entity colision radius)
  • param_name=param_value available params name are (there's more of them):
    • z (for Sprite)
    • name (for Sprite)
    • style (for every entity)
    • type (for ParticleSource)

Ejemplos

El código de una partícula humeante:

typeid=ParticleSource|type=Smoke

Una fresa:

typeid=Strawberry

Una figura de un arbol detras de los bloques delanteros:

typeid=Sprite|name=Tree1|z=-1

El inicio del jugador:

typeid=PlayerStart

El final del nivel:

typeid=EndOfLevel

Propiedades de Zonas

  • typeid=Zone
el único posible valor para una zona
typeid=Zone

Genera el archivo del Nivel

Atención: Guarda también tu nivel en formato .svg
.lvl es un formato con perdida, elimina información relacionada con las curvas bezier,
porque son reemplazadas por muchos vértices.
Además Inkscape no puede volver a abrir los archivos .lvl (si quieres, puedes escribir y enviarnos un patch para corregir esto).

Arrancar el Convertidor

Para guardar tu nivel dentro de un archivo con format .lvl, utiliza el menú File -> Save as... (o haz Shift-Ctrl-S) y escoge la extensión X-Moto Level, pon nombre al archivo del nivel y dale a Save.

Save-as.png

Una nueva ventana emergirá, has de poner:

  • level width : anchura del nivel en xmoto unit. Prueba diferentes hasta que encuentres la correcta
  • smoothitude : cuanto mas alto es el valor, mas suave sera el nivel. Pero no agregues muchos vértices, porque el xmoto no hace la escala muy bien si el nivel es muy grande con miles de vértices... y ira una poco mas lento...
  • lua script  : la ruta absoluta a tu script lua (dejalo vacío si no tienes ninguno)
  • level id  : el identificador del nivel (cada nivel ha de tener uno diferente)
  • level name  : el nombre del nivel en la lista de niveles
  • author  : tu nombre o apodo
  • description : pequeña descripción del nivel
  • sky  : el cielo que quieres utilizar en el nivel
  • rversion: la versión mínima necesitada para jugar a este nivel (por defecto 0.2.0).

L'rversion depende de las funciones que el script lua utiliza. (mirate Como crear un nivel dinámico utilizando el lenguaje Lua para una lista de las funciones lua y la versión del X-Moto en donde están disponibles)

Entonces el archivo se guardara en el directorio escogido en la ventana de Save as....

Importante: Hay un bug en el Inkscape. La primera vez que guardes un nivel con formato .lvl, has de poner algo en la caja de lua script (por defecto: None). Si no lo haces, el Inkscape es cerrara...

Script-params.png

Pon el archivo lvl que has generado en el directorio Levels del xmoto, y ya puedes jugar (fíjate que la hierba esta solo en la parte alta del bloque):

El nivel en el editor

El nivel en el X-Moto

El script agregara el archivo historial svg2lvl.log en tu directorio home ~/.

Archivos utilizados en esta guia