Difference between revisions of "Build from SVN"

From X-Moto
Jump to: navigation, search
(Ok, I can build it !)
(Ok, I can build it !)
Line 53: Line 53:
 
Right now, you can start xmoto with "<code>./xmoto</code>".
 
Right now, you can start xmoto with "<code>./xmoto</code>".
  
If sh ./bootstrap failed, you have to edit this two lines manually:
+
If sh ./bootstrap failed, you have to edit the ./bootstrap file manually:
 
  aclocal -I config $ACLOCAL_FLAGS\
 
  aclocal -I config $ACLOCAL_FLAGS\
 
  && automake --gnu --add-missing --copy \
 
  && automake --gnu --add-missing --copy \

Revision as of 09:16, 26 August 2006

CVS ?

X-Moto uses CVS to develop the game. With CVS files, you have access to new features and... new bugs. Use them only if you know what you do.

You must know that sources downloaded from CVS should not be compiled sometimes !

Wikipedia - CVS Sourceforge - X-Moto - CVS

Download latest files with CVS

For the first time, download all the files under "xmoto/" :

# cvs -z3 -d:pserver:anonymous@xmoto.cvs.sourceforge.net:/cvsroot/xmoto co -P xmoto

Update our files

When you already download all we need, you can update with this command :

# cvs -z3 -d:pserver:anonymous@xmoto.cvs.sourceforge.net:/cvsroot/xmoto -q update -d

Build

Dependencies

X-Moto must have the following to compile :

  • Latest gcc and g++
  • SDL development libraries and headers
  • OpenGL development libraries and headers
  • SDL_mixer with headers
  • libjpeg with headers
  • libpng with headers
  • zlib with headers
  • libbzip2 with headers
  • liblua50 with headers
  • liblualib50 with headers
  • libode0 with headers
  • libcurl3 with headers
  • automake >= 1.9

But with the new features, new dependencies can be asked.

Ok, I can build it !

$ cd xmoto
$ sh ./bootstrap
$ ./configure
$ make
# make install

Right now, you can start xmoto with "./xmoto".

If sh ./bootstrap failed, you have to edit the ./bootstrap file manually:

aclocal -I config $ACLOCAL_FLAGS\
&& automake --gnu --add-missing --copy \

so it looks like that:

aclocal-1.9 -I config $ACLOCAL_FLAGS\
&& automake-1.9 --gnu --add-missing --copy \

Doesn't work ?

Try to see where is the error and try to answer by yourself : the files on the CVS aren't supported by the development team.

TODO

The page is for linux, make it for other OS too. More explanations maybe ?