data['title']); if($title_nice != "Main Page") { echo "

"; echo $title_nice; echo "

"; } ?>

Deutsch - Català - Español - Norsk

Contents

Normal steps

Get the sources

The tarball is avaible on http://xmoto.tuxfamily.org/index.php?page=news.

Uncompress the tarball

tar zxf xmoto-x.y.z-src.tar.gz
cd xmoto-x.y.z

Compile

./configure [--prefix=/path_to_install]
make

Install

make install

Common errors

Did you install a compiler?

Some libraries are missing?

These commands should work in all debian based distros. List of debian based distros - http://distrowatch.com/dwres.php?resource=independence

In order to automatically install all the required packages (not including aclocal) in Debian/Ubuntu type:

sudo apt-get build-dep xmoto

aclocal

if this error message appears:

aclocal >= 1.9.6 is required !

in Debian/Ubuntu type:

sudo apt-get install automake

SDL_mixer

if this error message appears:

configure: error: SDL_mixer required

In Debian/Ubuntu type:

sudo apt-get install libsdl-mixer1.2-dev

liblua

if this error message appears:

configure: error: liblua5.1

in Debian/Ubuntu type:

sudo apt-get install liblua5.1-0-dev

libode0

if this error message appears:

configure: error: libode or libode0 required

in Debian/Ubuntu type (should work?):

sudo apt-get install libode0-dev

build-essential

if this error message appears:

configure: error: compiler can not create exectables

in Debian/Ubuntu type:

sudo apt-get install build-essential

sqlite3

if this error message appears:

configure: error: "sqlite3 required"

in Debian/Ubuntu type:

sudo apt-get install libsqlite3-dev

zlib

if this error message appears:

configure: error: zlib required

in Debian/Ubuntu type:

sudo apt-get install zlib1g-dev


libjpeg

if this error message appears:

configure: error: libjpeg required

in Debian/Ubuntu type:

sudo apt-get install libjpeg62-dev

libpng

if this error message appears:

configure: error: libpng required

in Debian/Ubuntu type:

sudo apt-get install libpng12-dev

libbz2

if this error message appears:

configure: error: libbz2 required

in Debian/Ubuntu type:

sudo apt-get install libbz2-dev

glu

if this error message appears:

configure: error: glu required

in Debian/Ubuntu type:

sudo apt-get install libglu1-mesa-dev

SDL_ttf

if this error message appears:

configure: error: SDL_ttf lib required

in Debian/Ubuntu type:

sudo apt-get install libsdl-ttf2.0-dev

liblualib50

if this error message appears:

configure: line 7589: exit: liblualib50: numeric argument required

in Debian/Ubuntu type:

sudo apt-get install liblualib50


libcurl

if this error message appears:

configure: error: libcurl required

in Debian/Ubuntu type:

sudo apt-get install libcurl3-openssl-dev


If you dont have any of these packages you can write this to install them all:

sudo apt-get install libsdl-mixer1.2-dev liblua5.1-0-dev libode0-dev build-essential libsqlite3-dev zlib1g-dev libjpeg62-dev libpng12-dev libbz2-dev libglu1-mesa-dev libsdl-ttf2.0-dev liblualib50 libcurl3-openssl-dev automake libsdl-net1.2-dev

This page was last modified on 26 November 2010, at 11:23. This page has been accessed 12,677 times.

  

Copyright © 2006